Contents

1. Introduction 1
   1.1. Data types 1
   1.2. Sections of this guide 1
2. The data area 2
3. Simple descriptive methods 3
   3.1. Analysing yields 4
   3.2. To link or not to link? 6
   3.3. Hidden data 7
   3.4. More percentiles and proportions 7
   3.5. Analysing qualitative or categorical data: factors 8
   3.6. More on frequencies 10
   3.7. Tidying up 11
   3.8. Review of points covered so far 11
4. More descriptive statistics 11
   4.1. Variate by a factor 12
   4.2. Factor by a factor 13
   4.3. Variate by a variate 14
   4.4. Combinations of more than two variables 15
   4.5. Two-way displays of the data 17
   4.6. Choosing the way to display results 18
5. Organising the data 18
   5.1. Unstacking 19
   5.2. Stacking 19
   5.3. Stacking two-way tables 20
6. The help system 20
   6.1. Accessing help 20
   6.2. Searching for help by keyword 23
7. In conclusion 24
   7.1. Good practice guides 24
   7.2. Adding a statistics package 24
   7.3. Getting the right answer 26

© Statistical Services Centre
The University of Reading, UK
Getting Started

If SSC-Stat has not already been installed, run the setup file to transfer the files onto your computer’s hard disk. Detailed setup instructions are provided on the CD and on the web download page. A ‘typical’ installation will include the example workbook files used in this Tutorial.

From within Excel, use Tools ⇒ Add-ins. Then use the Browse button to find the folder where the files were installed, and select the add-in file (SSC-Stat.xla). This process need be done only once: the add-in will automatically be available each time you subsequently load Excel.

How to use this tutorial

If you are new to Excel and computers, what should you do? The Tutorial assumes some prior knowledge of Excel. You will need to look elsewhere for introductory information on using Windows, managing files and working with Excel. Some resources are available on the CD and via the SSC website: follow the links to ‘Resources’ and look for ‘Basic Excel Materials’.

If you already have some knowledge of Excel, you could follow the ‘quick tour’, which comprises Sections 1 to 3. Then learn to use SSC-Stat’s help system, as described in Section 6.

The ‘full tour’ involves working through all the Sections and examples, ideally in sequence.

If you are experienced in both computing in general and Excel in particular, you could nevertheless gain some useful knowledge from the Tutorial. We suggest you skim through the materials in Sections 1 to 3 and start with Section 4.

Typographical Conventions

Variable names and file names are given in italics, e.g. Yield, Fertiliser, survey.wor.

Menu options, text on buttons and shortcut keys, and other information on dialogue boxes appear in the text in bold face, e.g. Tools ⇒ Add-ins, [F1].
1. Introduction

SSC-Stat is an add-in that extends the facilities within Excel for data management and statistical analysis. It is shown in Fig. 1a.

**Fig. 1a.** A view of Excel showing SSC-Stat’s main analysis menu

SSC-Stat is designed to support good statistical practice, which encourages exploration of the structure and relationships in the data using informative summaries, tables and graphs. Only when this has been done is it sensible to carry out more formal statistical analyses. We use SSC-Stat to support our use of Excel both to teach statistics and for data analysis.

In this tutorial we use an example dataset from a simple survey of rice production, distributed with SSC-Stat and shown in Fig. 1a. We assume the reader of this tutorial is already an Excel user, so we do not need to show how to type data, nor how to use Excel for simple calculations.

1.1. Data types

The data for analysis commonly include columns of two types.

- Columns containing numbers for analysis: we call them ‘variates’. These are values that investigators measure in their study. In the rice data, the columns named *Fertiliser*, *Yield* and *infected* are examples.

- Columns that indicate to which category a row of data belongs: we call these ‘factors’. They may be coded as 1, 2, 3, etc, or given as text, for example Male, Female. These are values that investigators record as characteristics of each outcome: in the rice data, *Village*, *Fertlevel* and *Variety* are examples. These give structure to data.

1.2. Sections of this guide

We describe the characteristics of the survey, both to outline the data in this tutorial and to allow you to use your own examples instead.

In the survey shown in Fig. 1a there are 36 ‘cases’ or rows of data. Nine measurements have been taken, so there are nine columns of data. The first row in Fig. 1a, gives the name of each column. The data are arranged in a single rectangular form that Excel calls a ‘list’. This is the layout that we assume in SSC-Stat. It is also a data layout that can easily be transferred to a statistics package or any other software.
We explain how to define the ‘data area’ as in Section 2. Then we consider analyses, using SSC-Stat’s Visualisation (or graphics) menu and Analysis menu in Sections 3 and 4.

In Section 3 we look at simple descriptive analyses, when we process just single columns of the data. We first look at the yields (a continuous variable or variate), and then at the varieties used (a factor or categorical variable).

In Section 4 we examine two or more columns together. If you wish to follow the steps using your own data, you will need two categorical columns corresponding to Village and Variety in Fig. 1a. You will also need two quantitative columns like Fertiliser and Yield.

In Section 5 we illustrate the facilities in SSC-Stat for (re)organising the data. In Section 6 we describe the help facilities in SSC-Stat.

SSC-Stat is designed to complement, rather than replace the extensive facilities in Excel that support statistical analysis. They include filters, sorting of data and so on. We will use these facilities at appropriate points in this tutorial.

2. The data area

We compare one aspect of a statistics package with the use of Excel for statistical analyses, to explain why we need an option to define the data area.

In a statistics package the results appear in a window separate from that of the spreadsheet (see Fig. 2a). Hence the software knows where the data are stored all the time. The columns available for analysis are only those in the active spreadsheet.

Fig. 2a. A typical statistics package (here Instat) has a separate window for results

![Fig. 2a](image)

In Excel, any results are either sent to a new sheet or simply placed alongside the data in the same sheet. Thus Excel does not differentiate clearly between data and results. To simplify the analysis it is therefore often useful to start by specifying the location of the data.
To define the data area in the survey worksheet, select (make active) any cell within the data array. Then use **General ⇒ Define Data Area** to bring up the SSC-Stat dialogue box (Fig. 2b). Click on the button to **Put Current Area into Standard Area** and choose the 2nd option, i.e. **Display Columns in the Standard Area before the Current Area**, as shown.

![Fig. 2b. Defining the data area in SSC-Stat](image)

This data area definition step is optional. In the next sections we will analyse the data and put results in further sheets in the workbook. If you do not define a data area, you must always return to the data sheet before doing a new analysis.

3. **Simple descriptive methods**

This section shows how to summarise single columns of data using the menus and dialogues.
3.1. Analysing yields

Fig. 3a. Visualisation ⇒ Boxplot

Use **Visualisation ⇒ Boxplot** as shown in Fig. 3a. Tick **Yield** as the variable to plot and press **OK**. The resulting boxplot is shown in Fig. 3b.

To help understand a boxplot, stay on this sheet and use the **Analysis ⇒ Descriptive Statistics** dialogue as shown in Fig. 3c. If there are no columns of data, i.e. if the dialogue is as in Fig. 3d, then you probably did not define the data area, as described in Section 2.

Fig. 3c. Analysis ⇒ Descriptive Statistics, with Additional statistics

---

1 Either define the data area, or return to the data sheet. From the data sheet you can specify that the results should be put on the same sheet as the boxplot.
Tick Yield as the variable to be summarised and check the box to give further statistics. Then tick the checkboxes to give the minimum, maximum, median and the quartiles, as shown in Fig. 3c. Also click the option to put results on the same sheet, so that you can compare the numerical results with the boxplot. Click OK.

Part of the results sheet is shown in Fig. 3e. This may be used to explain that a boxplot in Fig. 3b is a 5-number summary, where the 'box' shows the interquartile range. The lines – often called 'whiskers' – extend to the minimum and maximum.

To explore the options of this dialogue further return to the Analysis ⇒ Descriptive Statistics dialogue. Tick to request percentiles and type [0 25 50 75 100] in the box, as shown in Fig. 3f. (Rest the mouse pointer on the percentiles box: a tool-tip will guide you on what to type.) Finally, change the number of significant figures to 3 and press OK to get the results (Fig. 3g).

Check you follow the results. Note that when you ask for the 0% percentile, SSC-Stat simply gives the minimum value.
3.2. To link or not to link?

One advantage of using a spreadsheet for statistical work is that the data and results can be 'linked'. To explain what this means:

- return to the data sheet
- change the first yield from 53.6 to 153.6
- return to the results sheet.

You should see that some of the results (for example the boxplot and the maximum value) have changed automatically. The new boxplot is shown in Fig. 3h.

![Boxplot of Yield](image)

Now return to the data sheet and use Visualisation ⇒ Boxplot again. Tick the option to display the outliers. The dialogue should be as shown in Fig. 3i. Notice that now you do not have the option of linking. Press OK to give the boxplot in Fig. 3j. This shows the outlier clearly as a separate point.

![Boxplot with outlier](image)

Now return to the data sheet again and correct the first value of Yield back to 53.6. Then look at the two result sheets. You will see that the first boxplot has changed, but the second has not.
### 3.3. Hidden data

In this section we use some of Excel’s standard features in conjunction with SSC-Stat.

Marking a set of rows and using **Format ⇒ Row ⇒ Hide** will hide these rows from view. Columns can be hidden in a similar way. You can also hide rows in Excel's lists by using **Data ⇒ Filter**. The SSC-Stat dialogues always ignore hidden rows or columns. This feature adds greatly to the power of Excel for analysis. It can be used to eliminate rows where data are missing or to restrict analysis to a defined subset of the data.

If your data area also includes rows of results (which we do not recommend) then you can hide these rows before analysing the data.

As an example, we restrict the analysis to the village of Nanda. Use **Data ⇒ Filter ⇒ Autofilter**, click on the triangle in the **Village** cell (Fig. 3k) and select **Nanda**, then the only village shown. Notice that the row number changes colour to blue, indicating there are hidden rows.

Now recall the SSC-Stat **Analysis ⇒ Descriptive Statistics** dialogue box and click **OK**. SSC-Stat remembers the previous settings, so simply change the option to write the results to a new sheet. The results in Fig. 3l are now different because they come from the subset of 14 rows of data from Nanda village.

#### 3.4. More percentiles and proportions

Depending on the context, percentiles other than the quartiles may be of interest. Imagine the **Yield** column contains measurement of a substance whose high levels are toxic. Thus the upper quartile is no longer a satisfactory summary because a quarter of the values are higher than it. In this context, it is common to use higher percentiles like 90% or 95%.

First, use **Data ⇒ Filter ⇒ Autofilter** again to turn off the filtering and hence use all the data.

To obtain specific percentiles, return to the **Analysis ⇒ Descriptive Statistics** dialogue box, tick percentiles and type **90 95** in the box, then click **OK**. The relevant results are shown in Fig. 3m.
Thus only 10% of data is higher than 57.8 and only 5% of data are higher than 59.8 q/ha.\(^2\)

There are also situations in which it is of interest to know the proportion of data below or above given values. Say that in order to boost productivity, the central government has established that a province qualifies for incentives if at least 60% of its yields are lower than 45 q/ha and for extra incentives if at least 90% of its yields are lower than 55 q/ha.

In the **Analysis ⇒ Descriptive Statistics** dialogue box select *Yield* as variable to describe, tick proportions and type 45 55 in the box. Pressing **OK** gives the results in Fig. 3n.

Thus the province qualifies for incentives, as more than 60% of its yields are lower than 45 q/ha but not for the extra incentives, as less than 90% of its yields are lower than 55 q/ha.

### 3.5. Analysing qualitative or categorical data: factors

Factors are qualitative or categorical variables, namely codes that indicate to which group a row belongs. So summaries like percentiles may be meaningless for factors, whereas frequency counts give a more relevant description.

The number of categories (or levels) of a factor and the frequency of each category are important characteristics of a dataset. How many varieties were there in our survey and how many farmers used each variety?

#### Use the **Analysis ⇒ Summary Statistics** box as shown in Fig. 3o. Un-tick the **Variables** box, and the **By factor(s)** box will become ticked automatically. Select *Variety*, request the statistic **No of non-blanks** and **% non-blanks**. Then click **OK** to give the results in Fig. 3p.

Now use the **Visualisation ⇒ Category-Value Plot** dialogue as shown in Fig. 3q. If you click **OK** you have a simple bar chart as in Fig. 3r. Return to the dialogue and try other options, for example, a line chart.

---

\(^2\) There is no agreed way of calculating percentiles. The differences between the different methods occur, because of the need to interpolate between successive observations to give the required percentile. These differences are slight, unless the data set is small. In the SSC-Stat help we describe the method used in Excel.
We now make a deliberate mistake in the factor column, to see how it is reflected in the analysis:

- return to the data sheet
- change the first value in the Variety column from Old to Oldie
- use the Analysis ⇒ Summary Statistics dialogue again.

The resulting output is in Fig. 3s. It shows that any spelling mistake in the codes typed into a category, or factor column, results in a new category. The type of summary shown in Fig. 3s is a useful exploratory tool to check on this possibility, prior to the formal analysis.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Variety</td>
<td>CountAll</td>
</tr>
<tr>
<td>1</td>
<td>New</td>
<td>4</td>
</tr>
<tr>
<td>2</td>
<td>Old</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Oldie</td>
<td>16</td>
</tr>
<tr>
<td>4</td>
<td>Trad</td>
<td>15</td>
</tr>
</tbody>
</table>

Fig. 3q. Visualise ⇒ Category-Value Plot

Fig. 3r. Column chart
Correct the mistake before continuing. Here, as the summary in Fig. 3s indicates there is a single wrong value it is easy to retype. In general, to do this one would use Excel’s standard Edit ⇒ Replace facilities.

3.6. More on frequencies

In the survey data the column of fertiliser may be treated either as an ordinary column of data or as a factor. We look at it here as a factor. To find how many different amounts of fertiliser farmers used, return to the SSC-Stat Analysis ⇒ Summary Statistics dialogue box, tick Fertiliser instead of Variety and tick the box to give cumulative percentages as shown in Fig. 3t. The results are shown in Fig. 3u. (We used Format ⇒ Cells to specify one decimal place for the percentages.)

![Fig. 3t. Analysis ⇒ Summary Statistics](image)

Thus, a quarter of farmers applied no fertiliser, just over half applied no more than 150 kg/ha and three quarters applied no more than 200 kg/ha.

There are just 7 quantities of fertiliser because there are several repeats of each quantity. Though it may be tempting to consider this data column as qualitative, the repeats are the results of farmers using whole 50 kg bags. So it also makes sense to consider it as an ordinary variable, as we do in Section 4.
3.7. Tidying up

You have now produced many sheets of results. Delete the sheets before proceeding to the next section. One way is to use hold down <Ctrl> with the mouse click to mark the tab at the bottom of all the sheets except the one with the data. Then use Edit ⇒ Delete sheet.

3.8. Review of points covered so far

(i) You should have found that it was easier than you expected to get the results. Hence your future analyses can concentrate on deciding what you should do, rather than how to do it.

(ii) Why was it relatively easy to get the results? One reason is the extra facilities provided by SSC-Stat. But a second – and perhaps more important – reason is that the data were well organised before we started. They were arranged in a ‘list’, i.e. in columns, with each having a name at the top (as in Fig. 1a). If you want to learn more about lists, study SSC-Stat’s menu General ⇒ Help on Data Entry.

(iii) You have used two of the main menus in SSC-Stat, namely Visualisation to give graphs and Analysis to give summaries.

(iv) Visualisation ⇒ Boxplot was used to graph the results (Section 3.1 and 3.2), and Visualisation ⇒ Category–Value Plot (Section 3.4 was used to graph the frequencies.

(v) Analysis ⇒ Descriptive Statistics was used (Sections 3.1, 3.3 and 3.4) to give summary values of the yields, while Analysis ⇒ Summary Statistics was used to summarize the frequencies.

(vi) Some other aspects commonly needed in an analysis were introduced. The feature to hide data (Section 3.3) allowed us to analyse an important subset. It can also be used to omit unwanted rows of data before the analysis. We saw that different actions are needed to summarize ordinary columns, like Yield (Sections 3.1 to 3.4) and category (or factor) columns like Variety (Sections 3.4 to 3.6).

(vii) An analysis sometimes proceeds in stages, with the results of the first stage becoming the ‘data’ for the following stage. This was how we produced the column chart in Fig. 3r.

We will build on all these ideas in Section 4. In Section 5 we will introduce SSC-Stat’s third main menu, when we look at how to organise data that might not be arranged as we would like.

4. More descriptive statistics

Summaries often involve more than one column and we give some examples in this section. We will be sometimes analyse the data in stages, so the dialogues are slightly clearer if you start by returning to the dialogue and clearing the data area (Fig. 4a).
4.1. Variate by a factor

From the data sheet, use the SSC-Stat **Analysis ⇒ Summary Statistics** dialogue, as in Fig. 4b. Tick the boxes so that both a **Variable** and a **By factor** column can be specified. Tick **Yield** as the variable to summarise, by the **Variety** factor, and request the count, mean and standard deviation.

From the results in Fig. 4c, it seems that the ‘New’ variety has higher mean yield than the other varieties and it is more stable, i.e. has smaller standard deviation. However, this is based on only four values, so we must be cautious in these conclusions.

Boxplots can also be displayed for variates according to the level of a factor. Return to the data sheet and recall the **Visualisation ⇒ Boxplots** dialogue box. Tick **Variety** as the **By factor**, as shown in Fig. 4d, to give results as shown in Fig. 4e.
The range of values for the ‘Trad’ and ‘Old’ varieties is similar but the latter has higher values in general. The highest yield values are for the ‘New’ variety, which also has a narrower range. None of the three varieties shows an extreme value of Yield.

4.2. Factor by a factor

It may be interesting for the researcher to check which varieties were grown in each village, for example, to investigate the rate of adoption of the ‘New’ variety.

Start from the data sheet. Recall the Analysis ⇒ Summary statistics dialogue and un-tick the Variable(s) checkbox. Tick both Village and Variety as By factors (to tick two columns, hold down the <Ctrl> key when clicking on the second one) and request the number of non-blanks statistic only, as shown in Fig. 4f. The results are shown in Fig. 4g. (As an alternative, Excel’s pivot tables can be used to show these results as a 2-way table. An example of a pivot table will be shown later in Fig. 4r.)
4.3. Variate by a variate

Perhaps yield is boosted by the quantity of fertiliser applied. This could be investigated by finding the mean yield by fertiliser quantity. Return to the data sheet. In the Analysis ⇒ Summary Statistics dialogue, shown in Fig. 4h, add Yield again as the variable to be analysed and tick Fertiliser as the By factor. The resulting means are in Fig. 4i, and indicate that the more fertiliser is applied, the higher the yield.

A scatter plot might show the relationship between yield and fertiliser more clearly.

Place the cursor inside the results area in Fig. 4i, use Visualisation ⇒ X–Y Scatter Plot and complete the dialogue as shown in Fig. 4j. Choose the option to show the trend line. The graph is shown in Fig. 4k.

It seems that the mean yield increases roughly in a straight line in response to addition of fertiliser.
4.4. Combinations of more than two variables

The response of yield to fertiliser may also depend on the variety, as new varieties are bred to be more responsive to fertiliser. We first look at a graph. Use Visualisation ⇒ X-Y Scatter Plot and complete the dialogue as shown in Fig. 4l. Keep the option to show the trend line. The results are shown in Fig. 4m.
A numeric summary is also possible. Return to the data sheet and use the Analysis ⇒ Summary Statistics dialogue. Tick both Variety and Fertiliser as By factor(s). The relevant part of the dialogue is in Fig. 4n and the results are shown in Fig. 4o.

While it is clear that the ‘New’ variety is grown with at least 200 kg of fertiliser, it is less easy to see in this table how the other two varieties respond to fertiliser application. We now look at a graph to display these summary values.

Position the cursor inside the results list shown in Fig. 4o and use the Visualisation ⇒ X–Y Scatter Plot dialogue box; select Mean as the Y Variable, Fertiliser as the X Variable and Variety
as the **By factor**, as shown in Fig. 4p. Keep the option to draw lines. The results, after some customisation, are shown in Fig. 4q.

**Fig. 4p.** Plot using means

![Plot using means](image)

**Fig. 4q.** Plot to compare with Fig. 4m

![Plot of Mean against Fertiliser by Variety](image)

The lines are similar to those given in Fig. 4h where the graph showed all the data points rather than the mean. Are the trend lines the same? If not, then which ones should be reported?

### 4.5. Two-way displays of the data

The summary in Fig. 4o made it easy to use to produce the graph in Fig. 4q, but is not easy to use as it stands. Excel’s **Data ⇒ Pivot Table** and **Pivot Chart wizard** is a very powerful and useful facility for statistical work. It is described in standard guides on Excel. It is not part of SSC-Stat and is therefore not covered in this tutorial. If Excel’s pivot tables are new to you then investigate them further. Fig. 4r shows the same summary as shown in Fig. 4o, but in tabular form.

**Fig. 4r. Result from using Excel’s Data ⇒ Pivot Table menu**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Average of Yield</td>
<td>Fertiliser</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Variety</td>
<td></td>
<td>0</td>
<td>0.5</td>
<td>1</td>
<td>1.5</td>
<td>2</td>
<td>2.5</td>
<td>3</td>
</tr>
<tr>
<td>5</td>
<td>New</td>
<td></td>
<td>59.1</td>
<td>60.1</td>
<td>59.6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Old</td>
<td></td>
<td>31.8</td>
<td>40.4</td>
<td>43.2</td>
<td>43.3</td>
<td>40.5</td>
<td>54.8</td>
<td>50.0</td>
</tr>
<tr>
<td>7</td>
<td>Trad</td>
<td></td>
<td>26.9</td>
<td>32.7</td>
<td>28.2</td>
<td>37.7</td>
<td>42.7</td>
<td>30.0</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Mean</td>
<td></td>
<td>27.4</td>
<td>33.7</td>
<td>33.9</td>
<td>38.3</td>
<td>44.4</td>
<td>56.5</td>
<td>47.6</td>
</tr>
</tbody>
</table>

SSC-Stat does include a two-way display of either the data or the results. If, you select a cell in the list in Fig. 4o, and use **Manipulation ⇒ Unstack (Two-Way)**, SSC-Stat will re-arrange the results in a two-way display roughly as shown in Fig. 4r.

While Excel’s pivot tables provide a two-way display of the summary values, you can use SSC-Stat to look at the raw data in a two-way array with the dialogue box shown in Fig. 4s. The data are displayed as shown in Fig. 4t. For example with zero fertiliser we can see that the mean yield of 31.8 q/ha for the ‘Old’ variety is based on a single number, while the mean of 26.9 for the ‘Trad’ variety is the mean of 8 numbers whose individual yields varied from 19.1 to 37.6 q/ha.
4.6. Choosing the way to display results

The same tasks can be performed in both the **Analysis ⇒ Describe** and the **Analysis ⇒ Summary** dialogues, so why does SSC-Stat have two different dialogues? The difference is in how the results are displayed.

The **Describe** dialogue displays results in a tabular format, which is convenient for direct inclusion into a report without further manipulation, as you have seen in figures in Section 3.1 (e.g. Figs 3e and 3g). The results from the **Describe** dialogue can be considered as the final stage of descriptive analysis.

Instead, the **Summary** dialogue displays results in a list format. Though not normally included in reports, a list format is needed if the results themselves are to be re-used for, say, for displaying charts as we showed in Sections 3.5, 4.3 and 4.4. You can think of results from the **Summary** dialogue as an intermediate stage of descriptive analysis.

5. Organising the data

Data are often entered in Excel spreadsheets in the format most convenient to the data clerk. The format may mimic the field form thus making the data entry process easier and quicker. Or different operators may have entered data in separate sheets.
Imagine the yields had been entered separately for each village. Once copied onto the same sheet they are likely to have the layout we are going to produce in the next section. Then they would need to be manipulated to be in 'list' format.

5.1. Unstacking

Return to the datasheet and use SSC-Stat's Manipulation ⇒ Unstack dialogue. Unstack the Yield column by the factor Village as shown in Fig. 5a. The result is shown in Fig. 5b.

This tabular format is not suitable for efficient statistical work, as SSC-Stat works on lists and so do many of Excel's own statistical features, described in Section 1.2. So, if the data start as in Fig. 5b, then we need to 'stack' Yield by Village.

Fig. 5a. Manipulation ⇒ Unstack

Fig. 5b. Yields in separate columns

5.2. Stacking

Stay in the result sheet of Fig. 5b, and use SSC-Stat's Manipulation ⇒ Stack dialogue. Select all 4 columns to stack, change the default name of the data column to Yield and of the factor column to Village as shown in Fig. 5c. Part of the results are shown in Fig. 5d.

Fig. 5c. Manipulation ⇒ Stack

Fig. 5d. Data stacked in 'list' format
5.3. Stacking two-way tables

Sometimes we also have to stack a two-way tabulation, as in Fig. 4t. Place the cursor in the result sheet with the data in Fig. 4t, then recall the **Manipulation** ⇒ **Stack** dialogue. Tick all columns to stack except for **Variety**. You can select a block of adjacent columns in the dialogue by holding down the <Shift> key. Click the row factor option and select **Variety**. In the right-hand side of the dialogue (Fig. 5e), notice how you can change the order of output for the stacked columns. The third option on the left-hand side of the stack option frame is for including trailing blanks. There are 6 blank cells in this two-way table, which by default are not included when stacking. Should you need to keep blanks, tick this option. The results are in Fig. 5f.

---

6. The help system

The process of analysing data involves four steps: data entry, data management, visualisation and analysis. For each step, we give general recommendations in the help system for using Excel and the facilities provided by SSC-Stat.

6.1. Accessing help

---

**Fig. 6a. Help is available in each submenu**

<table>
<thead>
<tr>
<th>SSC-Stat</th>
<th>Window</th>
<th>Help</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Fig. 5f. Data back in 'list' format**

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Fertiliser</td>
<td>Variety</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>Old</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>7</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>8</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>9</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>10</td>
<td>0</td>
<td>Trad</td>
</tr>
<tr>
<td>11</td>
<td>0.5</td>
<td>Old</td>
</tr>
<tr>
<td>12</td>
<td>0.5</td>
<td>Trad</td>
</tr>
<tr>
<td>13</td>
<td>1</td>
<td>Old</td>
</tr>
<tr>
<td>14</td>
<td>1</td>
<td>Trad</td>
</tr>
<tr>
<td>15</td>
<td>1</td>
<td>Old</td>
</tr>
</tbody>
</table>
The help system appears in its own window. You can access it in three ways.

1. By pressing the Help button at the bottom of each dialogue box. This opens the section of online help relevant to the task in question. That is, pressing the Help button while in the Boxplot dialogue box shows the help for boxplots. So if you already know which task you need, access the help this way.

2. By selecting the appropriate Help submenu item in the SSC-Stat menu, as shown in Fig. 6a. This opens the sections of on-line help relevant to all the topics contained in the submenu. For example, the help accessed in Fig. 6a will show 6 topics corresponding to the 6 tasks available from the Analysis submenu (Fig. 6b). So if you know roughly what you want to do but would like help in choosing a task, access help this way.

3. By selecting the option Overview of SSC-Stat from the General submenu, as shown in Fig. 6c. This opens the help system at its top level, as in Fig. 6d, which shows all subsections that are accessible separately in the other submenus. So if you would like a tour of SSC-Stat features and pointers to the nature of statistical work, access the help this way.

Data analysis would often be improved if users started by asking: "Which tables and graphs could I provide that would best satisfy the objectives that led me to collect these data?" and not "Which test should I do?"
SSC-Stat is a suite of macros that extends the facilities within Excel for data management and statistical analysis. It is designed to support good statistical practice, which encourages exploration of the structure and relationships in the data using informative summaries, tables and graphs. Only after this exploration is it sensible to carry out more formal statistical analysis.

The process of analysing data involves four steps:

- **Data Entry**: Transferring the observed data values from paper or a computer file into an Excel workbook.
- **Manipulation**: Manipulation of (a copy of) the entered data to make the data more suitable for analysis.
- **Visualisation**: The use of graphics, tabulation and other techniques for exploring data. This helps you to understand the relationships within your data, and to identify possible errors and other problems.
- **Analysis**: Formal techniques for analysing and modelling the relationships within your data.

For each of these steps of the statistical process, we give general recommendations for using Excel and the extra facilities provided by SSC-Stat. Simply click on the names of the steps given above.
6.2. Searching for help by keyword

Sometimes you need help about topics that are not specifically mentioned in a heading of the help files. In this case you can search help by using keywords (see Fig. 6e).

Say you want information about how to represent with missing values in Excel. From within any help window press the **Search** button to activate the **Help topics** dialogue and while on the **Index** tab, type ‘missing’ in the top box as shown in Fig. 6e. You will see that index entry for **Missing Values** is highlighted. Press the **Display** button to open the relevant section of the Help file (shown in Fig. 6f).
Fig. 6f. Help on missing values

Our aim in this help is to support you in becoming more productive in your statistical work. Users may feel – often correctly – that there is more useful information in their data than they have revealed by their analysis. We want to assist those who wish to exploit their data fully. We would welcome your views about SSC-Stat. Please contact us via e-mail at statistics@lists.rdg.ac.uk.

7. In conclusion

This section is intended more for reading than practice, though you are welcome to try some of the tasks we describe. We cover a range of issues that affect those who use Excel for their statistical work.

7.1. Good practice guides

The Statistical Services Centre provides a set of statistical good-practice guidelines in printable, booklet format and as online help files. Some of the guidelines are fairly specific to Excel, such as ‘Excel for Statistics: Tips and Warnings’ and ‘Disciplined Use of Spreadsheet Packages for Data Entry’. Others are broader in scope, such as ‘Informative Presentation of Tables, Graphs and Statistics’ and ‘Confidence and Significance: Key Concepts of Inferential Statistics’.

The full list is available online within SSC-Stat from the menu General ⇒ Good Practice Guides. Printable versions are available on the CD and from the SSC web site: http://www.ssc.rdg.ac.uk/

7.2. Adding a statistics package

If you need more statistical facilities than are offered by Excel, it is easy to add a statistics package. In many packages the menus you will find are similar to those in SSC-Stat. We have called them Manipulation, Visualisation and Analysis. In Fig. 7a we show the menus of a popular package called Minitab. There are the standard Windows menus, plus the corresponding menus to organise the
data, to draw graphs and to do statistical analyses. Minitab calls these menus Manip, Graph and Stat respectively.

**Fig. 7a. Statistics packages have similar menus**

Most statistics packages also have dialogues similar to those in SSC-Stat, which makes the transfer even easier. For example, in Fig. 7b we show the dialogue in SSC-Stat for one-sample \( t \)-tests. The corresponding Minitab dialogue is shown in Fig. 7c.

**Fig. 7b. SSC-Stat dialogue for one-sample \( t \)-tests**
Almost all statistical packages can read Excel files, so, if you need more statistical facilities than are provided by the combination of Excel and SSC-Stat, it is straightforward to transfer your data.
7.3. Getting the right answer

Some statisticians claim Excel should not be used for statistical work, because the algorithms it uses are numerically unsound. For examples, look at:


To see what they mean you could open the worksheet called ‘algorithm.xls’ (Fig. 7d.) Here we consider the Excel function \texttt{stdev( )} to calculate the standard deviation of a set of numbers. You see from the first column, that the standard deviation of the numbers 1, 2, 3, 4, 5 is 1.58. If you add 10 to each number, i.e. make them 11, 12, 13, 14, 15 this does not change their spread. So, as shown in cell B8, the standard deviation is still 1.58. Look in the worksheet to see what happens when you add a really large number.

Fig. 7d. The algorithm.xls file shows the SSC\texttt{stdev( )} function gives a consistent results

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>ones</td>
<td>tens</td>
<td>hundreds</td>
<td>thousands</td>
<td>ten thousands</td>
<td>hundred thousands</td>
<td>ten million</td>
<td>hundred million</td>
<td>ten million</td>
<td>billion</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>101</td>
<td>10001</td>
<td>1000001</td>
<td>10000001</td>
<td>100000001</td>
<td>1000000001</td>
<td>10000000001</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>2</td>
<td>102</td>
<td>102</td>
<td>10002</td>
<td>1000002</td>
<td>10000002</td>
<td>100000002</td>
<td>1000000002</td>
<td>10000000002</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>13</td>
<td>103</td>
<td>103</td>
<td>10003</td>
<td>1000003</td>
<td>10000003</td>
<td>100000003</td>
<td>1000000003</td>
<td>10000000003</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>14</td>
<td>104</td>
<td>104</td>
<td>10004</td>
<td>1000004</td>
<td>10000004</td>
<td>100000004</td>
<td>1000000004</td>
<td>10000000004</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>15</td>
<td>105</td>
<td>105</td>
<td>10005</td>
<td>1000005</td>
<td>10000005</td>
<td>100000005</td>
<td>1000000005</td>
<td>10000000005</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1.58114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
</tr>
<tr>
<td>7</td>
<td>1.58114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
<td>1.68114</td>
</tr>
<tr>
<td>8</td>
<td>Row 8 gives the standard deviation using Excel's function \texttt{stdev}</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Row 9 gives the standard deviation using SSC-Stat's function \texttt{SSCstdev}</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

So, the critics are correct that Excel used suspect formulae to work out their statistics. It is easy to avoid the problem and SSC-Stat uses its own function, which we have called \texttt{SSCstdev( )} in its statistical routines. The function \texttt{SSCstdev( )} gives stable results, as shown in cell K9.

However, we do not agree with the conclusions of the authors that this is sufficient evidence for Excel to be avoided for statistical work. With simple examples, Excel only goes wrong with quite odd data sets, and we think you would notice when they are as odd as the data in columns J2 to J6 in Fig. 7d. So, with this proviso, we suggest that the use of Excel for descriptive statistics (graphs and tables) is fine.

However, Excel includes a statistical toolkit, and this adds facilities for multiple regression and many other types of analysis. Here we are less comfortable. Hence we suggest that if you need this type of method, you should add a statistics package to your repertoire. Others agree with our view, see for example:

www.agre research.cri.nz/Science/Statistics/exceluse1.html and
www.npl.co.uk/ssfm/ssfm1/validate/testing/excel.html

---

3 The example in Fig. 7d used Excel 97. The algorithm used for calculating the standard deviation was updated in Excel 2003.